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Learning Objectives

Terminal Learning Objectives

Able to use multiple techniques to upload
easyC programs and use VEXnet

Terminal = What you walk away with
Enabling = What you will be evaluated on

Enabling Learning Objectives

e Able to recognize and use USB Type A in
accordance with “IEC 62680”, USB
Implementers Forum, 2013

e Able to recognize and use RJ12 and RJ45
cables in accordance with “name”, creator,
year.

e Able to pair VEXnet devices in accordance
with “VEXnet User Guide”, VEX, 2015

e Able to upload easyC code to VEX Cortex
in accordance with “Programming With
easyC”, BEST Robotic, Inc., 2014



Terms & Abbreviations

Terminal (robotics) - Text based output from the robot program

Terminal (computers) - CLI where the user can type commands
Debugging - Troubleshooting, or the process of finding and solving errors
Cortex - The microcontroller of the VEX system, aka the brain.

EDR - this version of VEX, the previous was PIC

USB - Universal Serial Bus

Ethernet Cable - A cable used (typically) for internet connections

RJ12 - Registered Jack 12, similar to the RJ45 which is used for Ethernet



USB Types

Cell Phone chargers commonly use USB 2.0 Micro Type B
Printers commonly use USB 2.0 Type B

USB Extension Cables user USB Type A MALE to USB
Type A FEMALE

VEX uses USB Type A MALE to USB Type A MALE

MALE

USB 2.0 Type A Plug

USE 2.0 Type B Plug

USE 2.0 Mini Type B
Plug (4 Position)

USE 2.0 Mini Type B
Plug (5 Position)

FEMALE

USB 2.0 Type A Jack

USE 2.0 Type B Jack

USE 2.0 Type B Jack
(4 Position)

-

USB 2.0 Type B Jack
(5 Position)

MALE

USB 3.0 Type A Plug

USE 3.0 Type B Plug

USB 2.0 Micro Type B Plug

USB 3.0 Micro Type B Plug

FEMALE

USB 3.0 Type A Jack

USB 3.0 Type B Jack

USB 2.0 Micro Type B Jack

USE 3.0 Micro Type B Jack




Registered Jacks

Ethernet (internet) cables use RJ45, and has 8
pins/wires in the cable.

The USB to Serial adapter uses RJ12 - a smaller
connector with less pins than the RJ45

-

The RJ11 and the RJ12 are both used for telephone

lines, though the RJ11 standard only uses 4 wires, and RJ-I 1 HJ1 2 RJ45

the RJ12 uses 6.




Navigating the IDE



Recommended Settings

Click Tools -> Options

- easyC V5 for Cortex

File Edit WView

] w4 5 =

Function Blocks

Project Build and Download | Tools | Window  Help

L .==-;+:i Download Window...

i | i | Terminal Wir

-_r:a, Memory File Manager...

_3 On-Line Window...

# | competition Switch...
Options...
Choose Controller...

Upgrade VEXnet Firmware...



Recommended Settings

Select Build, then change Options
the drop down box to “Save Flow Chart  Dowrload
all changes” and click OK. Before buiding:

Build

Cancel




Download Firmware to Robot

You need to update firmware when switching between easyC and RobotC!
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Download Firmware to Robot

For these steps, we need the VEX Cortex and USB A-A Cable as pictured:
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Download Firmware to Robot

Connect the USB cable to
the VEX Cortex (as
pictured) and to a USB port
on the computer with easyC
running. If done correcitly,
“‘ROBOT” should be slowly
blinking RED, and “VEXnet”
should be solid GREEN.
NOTE: Cortex is turned
OFF.
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Download Firmware to Robot

In easyC, select Tools ->
Upgrade VEXnet
Firmware...

- easyC V5 for Cortex
File Edit View Project Buildand Dow

) s W IS

Function Elocks

nload | Tools | Window Help

i | E] | Terminal Window..,

=1l | Graphic Display...

-E Memaory File Manager...
_,3 On-Line Window...

#5 competition Switch...

Cptions..,
Choose Contraoller...

Upgrade YEXnet Firmware...

(K



Download Firmware to Robot

If the window looks like this, [ VEXnet Upgrade Utility V 4.1.7
then you are good! If not,
follow the appropriate steps.

Furictions

fl] ]

209105

VEXnet is up to date
No action required

Tearn 000N EX]

14



Download Firmware to Joystick

You need to update firmware when switching between easyC and RobotC!
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Download Firmware to Joystick

For these steps, we need the VEX Joystick and USB A-A Cable as pictured:
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Download Firmware to Joystick

Connect the USB cable to
the Joystick (as pictured)
and to a USB port on the
computer with easyC
running. If done correcitly,
“‘JOYSTICK” should be solic
RED, and “VEXnet” should
be solid GREEN. NOTE:
Joystick is turned OFF.

4‘/’4

72
v g a
(@]

*{i‘? 4182AA
use 3
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Download Firmware to Joystick

In easyC, select Tools ->

Upgrade VEXnet
Firmware...

- easyC V5 for Cortex
View  Project Build and Dow

) s W IS

Function Elocks

nload | Tools | Window Help

i | E] | Terminal Window..,

=1l | Graphic Display...

-E Memory File Manager...

_.3 On-Line Window...
#5 competition Switch...

Cptions..,

Choose Contraoller...

Upgrade YEXnet Firmware...
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Download Firmware to Joystick

If the window looks like this, [ VEXnet Upgrade Utility V 4.1.7
then you are good! If not,
follow the appropriate steps.

Furictions

fl] ]

VEXnet is up to date
No action required

Device in Ram Mode

*

COME
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Test Cortex

Testing the cortex is useful to ensure that everything is working when you are
trying to debug an issue. The following steps will show you how to make sure the
cortex and have code uploaded to it, and run the code, and display messages on
the terminal.
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Test Cortex

For these steps, we need the VEX Cortex and USB A-A Cable as pictured:
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Test Cortex

Connect the USB cable to
the VEX Cortex (as
pictured) and to a USB port
on the computer with easyC
running. If done correcitly,
“‘ROBOT” should be slowly
blinking RED, and “VEXnet”
should be solid GREEN.

2BUNTN
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Test Cortex

In easyC, select Build and
Download -> “Download
easyC Default Code”

¢ easyC V3 for Cortex

File Edit View Project |

Function Blocks

Build and D Tools Window Help

By

i.Fage » |

Pownload easyC Default Code

lownload IFI Default Code

MNew / Open
Standalone Project
tition Project

7= Open Project ...
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Test Cortex

Click Yes

[ ]

easyC V5 for Cortex

o Do you really want to download the easyC Default Code?
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Test Cortex

This dialogue box should
appear, wait for it to finish
downloading.

|ix| IFi/Intelitek Loader

ions  Help

0aC |:| Teminal | £ Graphic [Zlis|:||a‘,'| n Memory File Manager | g; Competition Switch Simulator |

VEX System Info

Cortex STM32F103VD COM5 115200
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Test Cortex

|ir| IFlfIntelitek Loader
Fo ine tiwénns. elp

Once it has downloaded
correctly, the Terminal
should pop up and
repeatedly show the text
pictured. If you get that,
then your cortex is working.

- Stop Clear

COM port is open... Cortex STM32F103VD |COMS 115200

26



Upload Sample Code

For these steps, we need the VEX Cortex and USB A-A Cable as pictured:
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Upload Sample Code

Connect the USB cable to
the VEX Cortex (as
pictured) and to a USB port
on the computer with easyC
running. If done correcitly,
“‘ROBOT” should be slowly
blinking RED, and “VEXnet”
should be solid GREEN.

2BUNTN
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Upload Sample Code

Open an internet browser
and go to

https://github.com/NPHS-P  rous

FR/EasyC-Samples, click
“Clone or download” ->
“Download ZIP”

NPHS-PFR / EasyC-Samples
£»Code (1) lssues Pull requests 0

ided. — Edit

Branch master = New pull request

." RoboticRice committed on GitHub

B gitig

Pull requests

Issues  Gist

@ Unwatch ~ 1

Settings

+ Star 0

i 1 contributor

Create new file  Upload files = Find fije

Help people interesied in this repository understand your project by adding a README.

Clone with HTTP

Open in Desktop

+

Y Fork 0

AS



Upload Sample Code

Right Click on the .zip file
and select “Extract All...”

Follow the prompts until the
files have been extracted.

Extract All...

Pin to Start




Upload Sample Code

- easyC V5 for Cortex - Joyctick Project (WiFi) - JoystickTest

Open up eaSyC V5 and go File | Edit WView Project Build and Dc-i.-u'ﬂl-:-;d Tools
to File -> Open Project... | Mew standalone Project o Bl Y | B | Q1o

"W StartPage x | “Z Main

raject Cirl+M

Projects

Recent Projects
i=m

Open Source File.., 1 New Standalone Pro

Project...

Print Constants & Variables...
Print Controller Configuration..,

Print Setup...

oystickTest.ECPX
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- Open easyC Project

Upload Sample Code T

#

Cluick access

Navigate to the JoystickTest
folder, and open up
“JoystickTest. ECPX”

<
Filz na

Files of type:

Description:
Templates
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Upload Sample Code

With the program loaded in
eaSyC for VEX and the C- easyC V5 for Curteu—Juysﬁ;kiject MiFi}'—Jog,rsl?ckast
Cortex Sti” Connected to the File Edit View Proje d Download | Tools  Window  Help

mpile Project Ctrl+F7 ;

ild and Download F7

i | g | QT10 v |Qf

computer, go to “Build and s > g

& mg;:"' Pl Download easyC Default Cade
. = Inpu
Download” - “Bu”d and ¢ D:tputs Download IFI Default Code ||:fig .
I +-{ %5 Speaker 'lGIc-lhals .
D own | oa d 5 Integ.rated Motor Encoders BEE;IN_

&
Variables

. |
(or you can hit F7) _ _ (=

L)

void main { wvoid }

JaystickToMotor ( 1 ,

SetMotor (-10 ,-127 )}

KK



Upload Sample Code

If this box appears, click
YES

& | easyC V5 for Cortex

The HEX file was successfully built,
Would you like to download the program?
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Upload Sample Code

This dialogue box should
appear, wait for it to finish
downloading.

|ix| IFi/Intelitek Loader

Fo Options  Help

’a; Download |:| Teminal | =11 Graphic [Zlis|:||a‘,'| n Memory File Manager | g; Competition Switch Simulator |

Cortex STM32F103VD COM5 115200
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Upload Sample Code

Once the terminal box
opens, the program has
been downloaded!

|ir| IFlfIntelitek Loader
Port Setting Dptiwéms. Help
; Downlosd - Terminal | =1 Graphic [Zlis|:||a‘,'| E Memoary File I"."Ianager.
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Communicate over wire

In order to operate the robot with a joystick, the joystick
must either be connected to the Cortex via USB cable
or Wifi - this will explain how to drive the robot with the
JoystickTest program already installed. Please note
that the specific program JoystickTest requires the use
of one Two-Wire motor as pictured, but motors are not
required to communicate between the Cortex and
Joystick.

NOTE: Joystick does not require batteries for wired
communications!
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Communicate over wire

For these steps we need the VEX Cortex, Joystick,
7.2V Battery & USB A-A Cable
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Communicate over wire

With the USB cable still
plugged into the Cortex and
the correct program already
downloaded, plug in the
7.2V battery into the Cortex
as pictured.
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Communicate over wire

Unplug the USB cable from
the computer (if you haven't
already) and plug it into the
Joystick.

NOTE: Joystick and
Cortex should now be
plugged into each other.

40



Communicate over wire

If using JoystickTest, plug
the 2-Wire motor into port 1 [r—
(for joystick control) or port | :
10 (for continuous power).
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Communicate over wire

Turn on the Cortex. It may
take a couple seconds for
the device to boot, but if it is
working the VEXnet light on
both the joystick and Cortex
should be solid green.

Make sure the light is green
for a solid 5 seconds to pair.

NOTE: Joystick does not
need to be turned on!
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Communicate over VEXnet

In order to use VEXnet, the two devices must be
paired using the WIRED method previously done.

This will start off from the end of the last instruction.
Please note that the specific program Joystick Test
requires the use of one Two-Wire motor as pictured,
but motors are not required to communicate between
the Cortex and Joystick.

NOTE: Joystick must have batteries for wireless
communications!
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Communicate over VEXnet

In order to change from Wired to Wireless (VEXnet)
we must now use 2 of the VEXnet USB wifi keys

NOTE: Make sure the Cortex
and Controller are turned off!
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Communicate over VEXnet

Unplug the USB cable from the Cortex and the Joystick.
Insert the USB Wifi keys in their place (as pictured)

|

2.4GH=z

Q
W
o
g
§
B

NOTE: This is the old

version, you should be
using two WHITE usb keys.
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Communicate over VEXnet

Turn both the Cortex and Joystick on - after about 5 seconds, the VEXnet light
should be fastly blinking green if it works, otherwise try again. If it works, you are

done!
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Upload Code over Joystick

Alternatively, you can program the Cortex by plugging the Joystick into the
computer and downloading code through it. This is useful if you have your cortex
on a robot and it is difficult to reach the USB port. Please note, the Joystick must
be connected to the Cortex either by USB cable, or a working VEXnet link.
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Upload Code over Joystick

On top of a fully functional Cortex and Joystick that communicate with each other,
you will also need the Programming Cable set:
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Upload Code over Joystick

Plug the RJ12 (see picture
A) into the Programming
port on the Joystick (see
picture B). Plug the USB
end into the computer while
EasyC is running. Make
sure both the Joystick and
Cortex are powered, and
then download code as
normal.
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Upload Code over Joystick

NOTE: While connected to the Joystick, you can still receive messages in the
Terminal from the Cortex as long as the Cortex is connected (over VEXnet or

USB) to the Joystick. etk

Programming VEXnet
USB A-A Cable Module RJ12 Cable Joystick

Wired Program & Debug
USE A-A Cable

Programming
Port.
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